Uncertain whether my just installed wallet will work!


#1

I downloaded the Windows wallet package and followed the readme instructions (Win7 Ultimate 64bit), but the browser window remained blank. Note: I changed the install directory at the provided install prompt. I’ve been reading through the two threads on BitcoinTalk and near the end of the second, someone reported a problem that sounds the same. The instruction for repair apparently involved creating a file “neoscoin.conf” with the following contents:

rpcallowip=127.0.0.1
rpcuser=neoscoin
rpcpassword=the-password-showing-from-the-command-window
listen=1
server=1

… and placing it in the target install directory. So I prepared the above file and placed it in the install directory, but I’ve no idea what the password was! I tried the run-setup file again, but its window closes immediately. I tried the run-neos file and it fired up my already installed wallet and opened a command window, saying it’s listening, but there’s no password to be seen. I opened up the browser window again (http://127.0.0.1:18000), but this time was told it couldn’t open the target, previous time it was an empty black screen.

I’m currently mining on two pools and need to transfer coins from them, but I’ve no idea whether my wallet will work correctly given my having selected a different install directory (it did download the blockchain during install) and my being unable to complete the .conf file. I did try searching my drives for a copy of neoscoin.conf with the hope of getting the password from it, but only my new one was found. Basically I need help making sure my wallet is installed properly and there’s no risk to my mined coins.

I’m used to fooling with PC’s, I just need to know what to do! If I need to back the whole thing out and start again, then I’ll do that (given appropriate instructions on how to back it out – hidden files or whatever)

In short – PLEASE HELP!

PS. I cannot use the default C: install location, there is insufficient disc space for a growing blockchain. I must use D:


#2

i just pinged syntaks to look at this for you, he should be chiming in any time :stuck_out_tongue:


#3

Hey,

 Do you have TeamViewer?  I could log in and fix it right up for you.

 Best regards,

syntaks


#4

Hi, thanks for getting in touch. No I don’t have that, know nothing of it. FWIW – The PC is on a LAN shared with a couple other machines plus a bunch of miners.


#5

Hey Syntaks, can you give me any instructions? Would my Wallet work reliably as is for just receiving and sending coins? I don’t really need any other features right now, just a simple wallet is good enough for now – as long as it’s reliable.


#6

This worked for me, quote from the BCT Thread:

Wherever you’ve set the custom datadir to - when you first ran neoscoin-qt - go in there and create neoscoin.conf (note: make sure it’s not .conf.txt). Put the following in there:

rpcallowip=127.0.0.1
rpcuser=neoscoin
rpcpassword=the-password-showing-from-the-command-window
listen=1
server=1

Then save it and restart the Qt wallet. Refresh the wallet interface in your browser and it should come up now. If not, just let me know and I’ll get you squared away. =) The password can be found in that command window where it reads http://neoscoin:@localhost

 Best regards,

syntaks

look for something like:

[Sun Sep 21 20:07:17 2014] 127.0.0.1:64736 [200]: / - Uncaught exception ‘Except
ion’ with message ‘Unable to connect to http://neoscoin:[password]@localhos
t:15004/’ in D:\Mining\Neos\wallet\include\jsonrpc.php:140


#7

I describe that fix in my opening post. Problem is I don’t have the password and don’t know how to regenerate that message following wallet install!

@Syntaks

I just installed TeamViewer and it makes me very uncomfortable allowing anybody complete control of one of my PC’s – an utter collapse of all security, I prefer you just tell me what to do!


#8

close the wallet software and run it using run-neos.bat
that will give you the command prompt with the exception message.


#9

also, i agree with your security concerns. I am the one syntaks replied to in the BCT thread.


#10

[quote=“becalmerill, post:8, topic:73, full:true”]
close the wallet software and run it using run-neos.batthat will give you the command prompt with the exception message.[/quote]
Tried that earlier and just now tried again. The exception message doesn’t appear, it just says it’s listening on the port address, specifies the “document root” (from which I ran the run-neos file – different from the install target address), and says Ctrl-C to quit.

It’s been several weeks now since you ran into that problem. Being able to select the install directory is an important option, every system isn’t vanilla – too bad he didn’t just fix the code!


#12

the installer hasnt changed since then. in fact, syntaks is hard at work on v2, which is why he isnt responding so quick here. I guess we wait for him then.


#13

If I don’t hear anything within a few hours, I’m just going to have to try backing the wallet out to start over. Trouble is, I suspect he’s tucked a file away somewhere that prevents easy back out. Have to see if I can spot anything in the roaming directory.


#14

[quote=“TrevorS, post:13, topic:73, full:true”]
If I don’t hear anything within a few hours, I’m just going to have to try backing the wallet out to start over. Trouble is, I suspect he’s tucked a file away somewhere that prevents easy back out. Have to see if I can spot anything in the roaming directory.[/quote]
Syntaks,

Am hoping it’s OK now!

Rebooted the system, renamed the extraction and target directories, re-extracted the wallet download package, remade the target directory, and proceeded with install. Got the needed password this time and saved the .conf file. After closing the wallet, re-opening it, and refreshing the browser everything seemed to go fine (got the dashboard info on the browser.).

Two things bother me though, the second install gave me no opportunity to enter a target directory and the long blockchain download didn’t take place, wherever the wallet’s keeping it, it isn’t in the target directory and my renaming the extraction and target directories didn’t prevent finding it. I previously looked for associated install files and didn’t find any, but there must have been at least one since the install went into the same directory as before. Though, it didn’t remember the wallet address and so I now have a new one for my pools.

By the way, the package needs an uninstall utility and also a procedure for moving a wallet from one location to another (be it disc drive or PC).

If there’s anything I need to double check following this quasi reinstall, please point me to it. Also, where is the blockchain kept and what/where’s the file that told the second install the location of the blockchain and the previous target directory?

Thanks – Trevor


#15

Glad you got it working. There are a bunch of upgrades and improvements coming with V2.

V1 was a very rudimentary install intended as an early release. Stick with it and you won’t be disappointed.


#16

yea, the installer of v1 was pretty rushed, because ‘investors’ ‘demanded’ it, version 2 has much more polish because syntaks and team have learned to do whats right, and not what people demand.
the new version has an actual proper windows installer, unlike v1


#17

Hey Trevor,

 My apologies I literally passed out at my desk.  The reason you weren't prompted a second time is because your data directory was already set and created.  The setup scripts for Neos just re-created your config files.  yak is right about the second version of the installer - the first one wasn't really all that intuitive so wer'e trying better for the new one.  Let me know if you need anything else or have any other questions and thanks for your support.

 Best regards,

syntaks


#18

Received my first Neos payout this morning and so clearly, my wallet install is working. Thanks for the inputs guys! :smile:


#19

Fantastic! =) Let us know if you need anything else.

Best regards,

syntaks